Issue with Signing in Athletes after class starts
Incident Report for Wodify Public
Resolved
This incident has been resolved.
Posted Feb 15, 2020 - 11:01 EST
Investigating
We're aware of the issue and our engineers are working towards a fix
Posted Feb 15, 2020 - 10:45 EST